Jumat, 12 Oktober 2012

Load Balancing Mikrotik

Apa itu Load Balancing Mikrotik.
Sekedar pengantar, untuk mengetahui apa itu Load Balancing Mikrotik, simak uarian berikut ini.
Secara harfiah, load balancing adalah pembagian beban menjadi seimbang (balance). Begitu juga artinya dalam dunia internet, server farm, dan jaringan komputer, load balancing adalah proses distribusi beban terhadap sebuah servis yang ada pada sekumpulan server atau perangkat jaringan ketika ada permintaan dari pengguna. Maksudnya adalah ketika sebuah sever sedang diakses oleh para pengguna, maka server tersebut sebenarnya sedang dibebani kerena harus melakukan proses terhadap permintaan para penggunanya. Jika penggunanya banyak, maka proses yang dilakukan juga menjadi banyak.

MikroTik adalah sistem operasi dan perangkat lunak yang dapat digunakan untuk menjadikan komputer menjadi router network yang handal, mencakup berbagai fitur yang dibuat untuk IP network dan jaringan wireless, cocok digunakan oleh ISP, provider hotspot, & warnet.
Mikrotik dibuat oleh MikroTikls sebuah perusahaan di kota Riga, Latvia. Bagi yang belum tau, Latvia adalah sebuah negara yang merupakan “pecahan” dari negara Uni Soviet dulunya atau Rusia sekarang ini.
mungkin teman teman bertanya apa sich mikrotik itu dan apa sich fungsinya berikut penjelasan nya

Cara Membuat Load Balancing Mikrotik
Disini mencoba membuat load balancing dengan menggunakan routerboard RB 750 indoor yang mempunyai 5 interface, apabila kita ingin membuat load balancing failover pada mikrotik versi 4.11, disini saya menggunakan 2 jalur input WAN dengan 1 jalur output yang ditujukan pada Local Area Network.
Disini diatur interface dengan setting
- LAN = 192.168.1.0/24
- Uplink = WAN 1 = 192.168.20.6/28
- Uplink = WAN 2 = 192.168.10.12/24
Disini saya menggunakan 2 ISP WLAN, kalo di tempat anda menggunakan telkom speedy maka lihat dulu line tersebut mempunyai gateway yang sama atau tidak .  Apabila gateway sama,  anda harus setting PPPOE (mikrotik yang dial PPPOE sendiri),  maka anda pilih salahsatu dari gateway yang sama itu buat PPPOE yang lain bikin setting PPPOE dial dari modem yaitu modem yang jadi gateway.  Hal ini digunakan biar traffik jalan dengan maksimal, biasanya kalo cuma PPPOE dial mikrotik dengan gateway yang sama loadbalancing kurang maksimal bahkan sering terjadi 1 gateway saja yang jalan aktif.
Setting di mikrotik versi 4.11 adalah sebagai berikut :
/ ip firewall mangle
add chain=prerouting action=mark-connection new-connection-mark=conn_1
passthrough=yes connection-state=new in-interface=LAN nth=2,1
add chain=prerouting action=mark-routing new-routing-mark=conn_1
passthrough=no in-interface=LAN connection-mark=conn_1
add chain=prerouting action=mark-connection new-connection-mark=conn_2
passthrough=yes connection-state=new in-interface=LAN nth=1,1
add chain=prerouting action=mark-routing new-routing-mark=conn_2
passthrough=no in-interface=LAN connection-mark=conn_2
/ip firewall nat
add chain=srcnat action=masquerade out-interface=WAN1 connection-mark=conn_1
add chain=srcnat action=masquerade out-interface=WAN2 connection-mark=conn_2?
/ip route
add dst-address=0.0.0.0/0 gateway=192.168.20.14 scope=255 target-scope=10 routing-mark=conn_1 comment=”"disabled=no
add dst-address=0.0.0.0/0 gateway=192.168.10.100 scope=255 target-scope=10 routing-mark=conn_2

Jika masih kurang jelas tentang load balancing mikrotik? klik di sini untuk sebarang pertanyaan....

Tidak ada komentar:

Poskan Komentar